POJ 1704 Georgia and Bob

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, …, and place N chessmen on different grids, as shown in the following figure for example:

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since “Lady first”. Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 … Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, “Georgia will win”, if Georgia will win the game; “Bob will win”, if Bob will win the game; otherwise ‘Not sure’.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

简单题意

在 1 * n 的格子上有一些石子
轮流将石子向右移动
不能移动的输

题解

将间隙看做石子
做阶梯博弈
及 将奇数层的石子看做 Nim 游戏
偶数层不用管

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int x[100005], b[100005];
int main(int argc, char const *argv[])
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        int n;
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &x[i]);
        }
        sort(x+1,x+n+1);
        for (int i = 1; i <= n; i++)
        {
            b[i] = x[i] - x[i - 1] - 1;
        }
        int S = 0;
        for (int i = n; i >= 1; i -= 2)
        {
            S ^= b[i];
        }
        if (S)
            printf("Georgia will win\n");
        else
            printf("Bob will win\n");
    }
    return 0;
}
本文作者 : NekoMio
知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议进行许可。
本文链接 : https://www.nekomio.com/2017/07/30/52/
上一篇
下一篇